Unable to login to my.canary.is / Canary app
Incident Report for Canary
Resolved
We have resolved the incident causing authentication related issues with my.canary.is. and login to the Canary app.
Posted 16 days ago. Jun 13, 2017 - 23:44 EDT
Investigating
We are investigating reports of customers experiencing authentication related issues with my.canary.is. Customers may see one of the following errors "Sorry, you've exceeded the number of login attempts, please try again later" or "502 Something's not right." The following features are affected:

• Login to my.canary.is
• Login to Canary app (iOS and Android)
• Password resets
• Membership upgrades
Posted 16 days ago. Jun 13, 2017 - 11:07 EDT