Error viewing previously saved timeline events
Incident Report for Canary
Resolved
All timeline entries from the previous 30 days that pre-dated March 8th, 2017 should now be fully viewable. Thank you again for your patience during this past week as our engineers re-populating this data to your timelines systematically in order to ensure that no data was lost.
Posted 7 months ago. Mar 15, 2017 - 17:43 EDT
Monitoring
Our engineers are continuing to perform maintenance on all customers timelines. We expect this process to continue for the remainder of the week. During this time window we do not expect any further service issues as a result of the ongoing maintenance. You may however still encounter an unplayable video from prior to 3/8 until the restore process is completed, but all previously bookmarked videos are now fully restored. Canary cloud service is fully operational at this time. We appreciate you hanging in there during this timely process.
Posted 7 months ago. Mar 14, 2017 - 15:50 EDT
Update
All bookmarked data prior to March 8th has been restored to customers timelines as of this morning. As we continue to perform maintenance on the remainder of your timeline history prior to March 8th, you should no longer encounter app connectivity issues or delays in processing of videos and notifications. We apologize for this instability of your Canary cloud service and hope to have a full resolution soon.

The following features are affected on Android:
* Viewing of timeline events before 3/8
* Exporting videos does not display processing stage
* Viewing and submitting comments on videos
* Tagging videos
* Missed mode change commands

The following features are affected on iOS:
* Viewing of timeline events before 3/8 may result in an app crash
* Missed mode change commands
Posted 7 months ago. Mar 14, 2017 - 08:25 EDT
Update
We have been working around the clock to resolve all issues customers may still be experiencing with the viewing of previously saved timeline events prior to 3/8/17. As we perform system maintenance to post the event data back to your timelines, you will continue to see some erratic app behavior as well as delays in processing of videos and notifications. We apologize for the continued degradation of your Canary service and hope to have a full resolution to this issue over the next 24 hours.

The following features are affected on Android:
* Viewing of some bookmarked and timeline events before 3/8
* Exporting videos does not display processing stage
* Viewing and submitting comments on videos
* Tagging videos

The following features are affected on iOS:
* Viewing of some bookmarked and timeline events before 3/8 may result in an app crash
Posted 7 months ago. Mar 13, 2017 - 15:41 EDT
Update
Our engineers are currently working to restore access to saved timeline events before 3/8/17. During this restoration period, you may experience an issue accessing the application, as well as delays in videos and notifications. We appreciate your patience while we work towards a final resolution.
Posted 8 months ago. Mar 11, 2017 - 14:09 EST
Update
Our engineers are still working towards a full resolution in the viewing of saved timeline events prior to March 8th. These events will continue to be inaccessible until the issue has been resolved. Customer may additionally see some delays in video processing and notifications being sent for created videos this evening.
Posted 8 months ago. Mar 09, 2017 - 22:04 EST
Update
We are currently experiencing an issue with viewing saved Timeline events. Timeline events prior to March 8th will be inaccessible until the issue has been resolved. Our engineers are actively working to get this resolved as quickly as possible. All new Timeline events are able to be viewed and accessed as normal.
Posted 8 months ago. Mar 08, 2017 - 17:29 EST
Identified
Our engineers have identified the root cause of the issue and are actively working towards a resolution. Currently you may experience an issue viewing or downloading previously recorded timeline events. We appreciate your patience while we work towards a resolution to this issue.
Posted 8 months ago. Mar 08, 2017 - 15:12 EST
Investigating
We are currently investigating short delays in video processing and notifications being sent for created videos.
Posted 8 months ago. Mar 08, 2017 - 14:02 EST