Customers unable to sign up for Membership
Incident Report for Canary
Resolved
The earlier issue with signing up for or making modifications to your Canary membership plan has been resolved. If you continue to see issues with membership please report them to Canary support.
Posted 4 months ago. Feb 15, 2017 - 12:42 EST
Investigating
Currently, there is an issue with signing up for or making modifications to your Canary membership plan. Our Operations team is aware and investigating the issue with our vendor.
Posted 4 months ago. Feb 15, 2017 - 12:05 EST