Canary Flex Service Issues
Incident Report for
Canary
Resolved
The previous service issue has been resolved.
Posted
Nov
08
,
2017
-
19:58
EST
Investigating
We are currently investigating an issue that is affecting set ups, watch live and mode changes for Canary Flex devices.
Posted
Nov
08
,
2017
-
16:43
EST
×
Subscribe to Incident
Subscribe to updates for
Canary Flex Service Issues
via . You'll receive .